
Photo to 3D Rotatable Object 



In this lesson, we will explore the new "Rotate Object" feature in Adobe Photoshop, which 
allows you to convert 2D photos into 3D objects that can be rotated and manipulated in 
three-dimensional space.	

Key Concepts Covered in This Lesson:	

● Rotate Object Feature (01:27): Understand how to use this new Photoshop tool to 
transform a 2D image into a rotatable 3D object.	

● Select Subject (01:02): Learn how the tool uses AI to automatically select the main 
subject of your image, which is crucial for the Rotate Object function.	

● 3D Layer (01:39): Recognize that Rotate Object creates a special layer that allows for 
3D manipulation, distinct from standard Photoshop layers.	

● Low-Resolution Preview (02:10): Be aware that during the rotation process, the 
image will be displayed in low resolution for faster manipulation.	

● Contextual Taskbar (03:41): Utilize the contextual taskbar for quick access to rotation 
controls and to finalize the transformation.	

● Properties Panel (04:01): Discover the additional rotation controls available in the 
Properties panel for more precise adjustments.	

● Free-Form Transformation (04:17): Learn how to perform more fluid, unconstrained 
transformations by using right-click or Control-click.	

● High-Resolution Rendering (05:14): Understand that once you finalize the rotation, 
Photoshop renders a high-resolution version of the object.	

● Generative Credits (05:53): Be mindful that this feature consumes generative credits, 
with a certain number of free trials available.	

● Edit Rotation (06:17): Know that you can re-edit the rotation of an object without 
incurring additional credit costs after the initial conversion.	

● 3D Gaussian Splatting (44:32): Gain insight into the underlying technology that 
enables the 2D to 3D transformation.	

● Defringe (43:13): Learn how to use this feature to eliminate halos or fringing artifacts 
that can appear on the edges of transformed objects.	

Getting Started with Rotate Object	
The Rotate Object feature transforms a 2D photograph into a 3D object that can be rotated 
in any direction. This is particularly useful for compositing, allowing you to place an object 
from one photo into another at a different angle.	

Preparing Your Image	
Before you can use the Rotate Object feature, you need to ensure your layer is ready for 
transformation by doing one of the following:	

1. Unlock the Background Layer: If you are working on a background layer, it will be 
locked. To enable transformations, you need to unlock it. This is typically done by 
double-clicking the layer or clicking a lock icon for the layer in the Layers panel.	

2. Make a Selection and Isolate to a New Layer: The ideal workflow is to make a 
selection of the object you want to transform and place it on its own layer by 
choosing Layer>New>Layer Via Copy. This ensures that Photoshop knows exactly 
what you want to work with. If you don't make a selection, Photoshop will attempt to 
use its "Select Subject" feature to identify the object.	
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Initiating the Rotate Object Transformation	
Once your image is prepared, you can begin the 3D 
transformation process.	

1. Access Rotate Object: Navigate to the Edit menu and 
select Rotate Object. If the option is grayed out, 
ensure you are working not working on a layer called 
Background.	

2. Wait for Transformation: Photoshop will process the 
image and convert it into a special 3D layer. This 
process might take some time, especially for complex 
images. During this stage, the image will appear in low 
resolution.	
Note: It's advisable to duplicate your layer before 
applying this transformation if you wish to preserve the 
original.	

Manipulating the 3D Object	
After the object has been converted to 3D, you can begin to 
manipulate its orientation and perspective.	

Rotation Controls	
The interface provides several controls for rotating your 3D object.	

● Blue Icons on the Canvas: You'll notice blue icons 
on the image canvas that allow for manipulation.	

○ Horizontal Rotation: The bottom icon 
allows you to rotate the object 
horizontally.	

○ Vertical Rotation: The icon on the left 
enables vertical rotation.	

○ Perspective/Lens Distortion: The icon on 
the right allows you to change the 
perspective, similar to adjusting a camera 
lens's zoom or controlling lens distortion. 
This affects how the front of the object 
appears in relation to its distance.	

Contextual Taskbar Controls	
The contextual taskbar offers quick access to these same rotation functions and more.	

● Rotate, Tilt, and Reset: You can find controls for rotating, tilting, and returning the 
settings to their original position within the taskbar.	
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Properties Panel Controls	
For more granular control, the Properties 
panel offers an additional rotation dimension.	

● Spin Around Center: In addition to 
horizontal and vertical rotation, the 
Properties panel provides a control to 
spin the object around its center point. 
This is useful for fine-tuning after the 
main rotation is set.	

Free-Form Transformation	
For more dynamic manipulation, you can engage a free-form transformation mode.	

● Right-Click or Control-Click: Instead of left-clicking, right-click (or Control-click on a 
Mac) on the object to enable free-form movement. This allows you to drag and 
reposition the object freely. For many trackpad users, a two-finger click often serves 
as the equivalent of a right-click.	

● Corner Handles: Standard transformation handles are available at the corners, 
allowing you to resize and reposition the object more precisely.	

Finalizing the Transformation	
Once you are satisfied with the rotation and positioning, you can render the final high-
resolution image. Click the "Done" button on the contextual taskbar, or press Return or 
Enter on your keyboard. Photoshop will then process the object to produce a high-
resolution version based on your adjustments. This rendering process can take some time.	

Credit Consumption	
The Rotate Object feature uses generative credits.	

● Initial Conversion: 20 credits are consumed only when the 2D image is initially 
converted into the special 3D layer.	

● Free Trials: The first three uses of the feature do not deduct credits, allowing you to 
experiment freely.	

● Subsequent Edits: Editing the rotation of an already converted 3D layer does not use 
additional credits.	

Special 3D Layers	
The feature creates a unique layer type that has specific characteristics.	

● 3D Layer Icon: These special layers are indicated by an icon in the lower-
right corner of the layer thumbnail in the Layers panel.	

● Non-Destructive Editing: You can re-edit the rotation of these layers by going to Edit 
> Edit Rotation or through the Properties panel without additional credit cost.	

Creating Variations with Incremental Rotation	
You can generate multiple versions of an object by applying incremental rotations.	
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1. Apply Rotation: Use the numerical controls in the Properties panel for precise 
rotation and enter 45 into the horizontal rotation field.	

2. Duplicate Layer: Duplicate the 3D layer by typing Command-J (CTR-J on PC).	
3. Add Incremental Rotation: With the duplicate layer active, click on the horizontal 

rotation field in the Properties panel and type +45 to the right of the value that is 
already in the field and press Enter twice.	

4. Repeat: Continue duplicating and adding incremental rotations to create a series of 
variations.	

Distortion and Artifacts	
The AI's interpretation of 3D space can sometimes lead to unexpected distortions or 
artifacts, especially when rotating in multiple dimensions.	

● "Hallucinations": The AI might add details or alter existing structures in ways that 
were not present in the original 2D image, especially when trying to reconstruct 
unseen parts.	

● Low-Resolution vs. High-Resolution Discrepancies: Sometimes, the object looks 
correct in the low-resolution preview but develops artifacts when rendered at high 
resolution. This suggests that the AI might be "guessing" details during the high-
resolution render.	

Recovering the Original Layer	
If you forget to duplicate your layer before converting it 
to 3D, there's a method to recover the original.	

1. Create a New Empty Layer: Add a new, empty 
layer above your original image.	

2. Fill with History: Go to Edit > Fill. Choose 
"History" as the fill option. This will fill the new 
layer with the state of your document when it 
was initially opened.	

Example: Old Movie Projector	
The AI successfully interpreted the round lens and the dual-sided reels of a movie projector. 
It also managed to recreate the feet of the projector, even though only one was clearly 
visible.	
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Example: Chair Rotation and Integration	
To place a rotated chair into a new room, the process 
involved selecting the chair, rotating it, and then using 
layer masks to conceal parts of the chair that overlapped 
with existing elements in the new scene. The Harmonize 
feature was then used to adjust lighting and shadows to 
better match the new environment.	

Example: Airplane Rotation	
Rotating an airplane showed how the AI interprets unseen 
parts. In one instance, it seemed to add a third propeller 
blade and stabilization wires between the wings, indicating 
it's inferring details based on its training data.	

Improving Selection Accuracy	
The accuracy of the initial selection directly impacts the quality of the 3D object.	

● Object Selection Tool: Use the Object Selection Tool to select your subject. Be aware 
that the preview may not be perfectly accurate, but the final selection often is.	

● Refining Selections: If the results are not satisfactory, go back and refine your 
selection. Exclude areas that might confuse the AI, such as unwanted elements or 
hidden parts that the AI might misinterpret.	
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Masking for Integration	
Layer masks are essential for seamlessly integrating the rotated object into a new scene.	

● Hiding Overlapping Areas: Use layer masks to hide parts of the rotated object that 
should be behind other elements in the background scene.	

● Option/Alt Key for Masking: To mask out selected areas, hold down the Option 
(Mac) or Alt (Windows) key while clicking the layer mask icon to invert the mask.	

Dealing with Fringing Artifacts	
Fringing, or halos, can appear on the edges of 3D layers when composited.	

1. Rasterize the Layer: Before applying the defringe effect, convert the 3D layer into a 
regular pixel layer. Right-click on the layer in the Layers panel and choose Rasterize 
Layer. This removes the 3D functionality.	

2. Apply Defringe: Go to Layer > 
Matting > Defringe. A dialog 
box will appear asking for the width 
of the fringe to remove. The default 
of one pixel is often sufficient.	
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Technical Requirements	
For the Rotate Object feature to function, several conditions must be met:	

● 8-Bit Documents: The feature only works on 8-bit documents. If you have a 16-bit 
image, you'll need to convert it to 8-bit via Image > Mode > 8-bit.	

● Internet Connection: This feature requires an active internet connection to function.	

● RGB Mode: The document must be in RGB color mode. It will not work in CMYK or 
grayscale modes.	

● Pixel Layers: The layer you are working on must contain pixels. Text layers or shape 
layers will not work directly. Converting them to smart objects might enable the 
feature.	

Reasons for Feature Being Grayed Out	
If the "Rotate Object" option is grayed out, consider these possibilities:	

● Layer Visibility or Opacity: Ensure the layer you're working on is visible and has an 
opacity of 50% or higher.	

● Educational Accounts: On some educational accounts, particularly K-12, this feature 
may be blocked. Higher education administrators can also choose to disable it.	

Underlying Technology: 3D Gaussian Splatting	
The core technology enabling this 2D to 3D transformation is known as 3D Gaussian 
Splatting. This method essentially breaks down a 2D image into numerous points in 3D 
space. These points can then be rotated and re-rendered, allowing for dynamic 
manipulation. The process is fast at low resolution but can be time-consuming for high-
resolution renders.	

The Rotate Object feature is a powerful new tool in Photoshop that significantly enhances 
creative possibilities for compositing and 3D manipulation. By understanding its 
functionalities, controls, and potential limitations, users can effectively transform 2D images 
into dynamic 3D objects. The ability to rotate, adjust perspective, and integrate these 
objects into new scenes, coupled with techniques for refining selections and resolving 
artifacts, makes this feature a valuable asset for digital artists and designers. While some 
challenges remain, particularly with complex geometries and AI interpretation, the ongoing 
development of such AI-driven tools promises even more sophisticated capabilities in the 
future.
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